import Foundation
let pattern = #"^(?!\(\d{3}\) \d{3}-\d{4})(?:(\+\d{1,2}\s?|\b)?(\(?\d{3}\)?[\s.-]?|\b)\d{3}[\s.-]\d{4}\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(123) 456-7543
123 456 7832
(456)123-7905
+1(456) 234-1812
+22 (795)372-4902
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)