$re = '`[Z][0-9]`m';
$str = 'Z001
Z065
Z965
ZB01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);