// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https?://\S+?cnbc\.com\S+").unwrap();
let string = "
I have a text file of links after scrapping, I need to make a regular expression for these links so i can extract them from a file, but different links have same structure but different in length, like
https://www.cnbc.com/2016/10/12/billionaire-richard-branson-learned-a-key-business-lesson-playing-tennis.html
and this:
https://www.cnbc.com/2016/10/12/hedge-fund-bonus-makeover.html
I can successfully make RE for the base domain, but after that title give me a tough time, mine is
[h][t][t][p][s]:\\/\\/[w][w][w].[c][n][b][c].[c][o][m]\\/[2][0][1][5-8]
for https://www.cnbc.com/2016/10/11/ but dont know how to make for further with diiferent words for different links ahead,
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}