package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:https?:\/\/)?((?:[^\/\.]+\.)*)([^\/\.]+\.[^\/\.]+)((\/\w+)*)?`)
var str = `domain.com/
http://domain.com/p1/p2/p3/p4
https://example.a.domain.com/foo/bar/a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}