$re = '/(?:https?:\/\/)?((?:[^\/\.]+\.)*)([^\/\.]+\.[^\/\.]+)((\/\w+)*)?/m';
$str = 'domain.com/
http://domain.com/p1/p2/p3/p4
https://example.a.domain.com/foo/bar/a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);