# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/https:\/\/www\.google\.com\/search\?(?:udm=\d+)?(.*(?=&udm=\d+))?([^#]+(?:&udm=\d+)?)(#.+)/https:\/\/www.google.com\/search?udm=14$1$2/g;t' <<< "https://www.google.com/search?udm=3&q=windows+11+switch+keyboard+layout&client=firefox-b-d&sca_esv=289553745bb9d363&ei=A6BOaLukDsaoxc8Pu5vviQI&oq=windows+11+switch+keyboard+layout&gs_lp=Egxnd3Mtd2l6LXNlcnAiIXdpbmRvd3MgMTEgc3dpdGNoIGtleWJvYXJkIGxheW91dCoCCAAyBRAAGIAEMgYQABgWGB4yBhAAGBYYHjIGEAAYFhgeMggQABiABBiiBDIIEAAYgAQYogQyBRAAGO8FMgUQABjvBUiNUVCWBljIQnABeAGQAQCYAXigAdQUqgEEMjguNbgBA8gBAPgBAZgCIqACxBbCAgoQABiwAxjWBBhHwgILEAAYgAQYsQMYgwHCAggQABiABBixA8ICDhAAGIAEGLEDGIMBGIoFwgIKEAAYgAQYQxiKBcICCBAuGIAEGLEDwgIOEC4YgAQYxwEYjgUYrwHCAggQABgWGAoYHpgDAIgGAZAGCJIHBDI5LjWgB7ngAbIHBDI4LjW4B7oWwgcGMi0yNS45yAfWAQ&sclient=gws-wiz-serp#vhid=zephyr:0&vssid=atritem-
https://www.google.com/search?q=windows+11+switch+keyboard+layout&client=firefox-b-d&sca_esv=289553745bb9d363&ei=A6BOaLukDsaoxc8Pu5vviQI&oq=windows+11+switch+keyboard+layout&gs_lp=Egxnd3Mtd2l6LXNlcnAiIXdpbmRvd3MgMTEgc3dpdGNoIGtleWJvYXJkIGxheW91dCoCCAAyBRAAGIAEMgYQABgWGB4yBhAAGBYYHjIGEAAYFhgeMggQABiABBiiBDIIEAAYgAQYogQyBRAAGO8FMgUQABjvBUiNUVCWBljIQnABeAGQAQCYAXigAdQUqgEEMjguNbgBA8gBAPgBAZgCIqACxBbCAgoQABiwAxjWBBhHwgILEAAYgAQYsQMYgwHCAggQABiABBixA8ICDhAAGIAEGLEDGIMBGIoFwgIKEAAYgAQYQxiKBcICCBAuGIAEGLEDwgIOEC4YgAQYxwEYjgUYrwHCAggQABgWGAoYHpgDAIgGAZAGCJIHBDI5LjWgB7ngAbIHBDI4LjW4B7oWwgcGMi0yNS45yAfWAQ&udm=5&sclient=gws-wiz-serp#vhid=zephyr:0&vssid=atritem-
https://www.google.com/search?q=windows+11+switch+keyboard+layout&client=firefox-b-d&sca_esv=289553745bb9d363&ei=A6BOaLukDsaoxc8Pu5vviQI&oq=windows+11+switch+keyboard+layout&gs_lp=Egxnd3Mtd2l6LXNlcnAiIXdpbmRvd3MgMTEgc3dpdGNoIGtleWJvYXJkIGxheW91dCoCCAAyBRAAGIAEMgYQABgWGB4yBhAAGBYYHjIGEAAYFhgeMggQABiABBiiBDIIEAAYgAQYogQyBRAAGO8FMgUQABjvBUiNUVCWBljIQnABeAGQAQCYAXigAdQUqgEEMjguNbgBA8gBAPgBAZgCIqACxBbCAgoQABiwAxjWBBhHwgILEAAYgAQYsQMYgwHCAggQABiABBixA8ICDhAAGIAEGLEDGIMBGIoFwgIKEAAYgAQYQxiKBcICCBAuGIAEGLEDwgIOEC4YgAQYxwEYjgUYrwHCAggQABgWGAoYHpgDAIgGAZAGCJIHBDI5LjWgB7ngAbIHBDI4LjW4B7oWwgcGMi0yNS45yAfWAQ&sclient=gws-wiz-serp&udm=5#vhid=zephyr:0&vssid=atritem-
https://www.google.com/search?q=windows+11+switch+keyboard+layout&client=firefox-b-d&sca_esv=289553745bb9d363&ei=A6BOaLukDsaoxc8Pu5vviQI&oq=windows+11+switch+keyboard+layout&gs_lp=Egxnd3Mtd2l6LXNlcnAiIXdpbmRvd3MgMTEgc3dpdGNoIGtleWJvYXJkIGxheW91dCoCCAAyBRAAGIAEMgYQABgWGB4yBhAAGBYYHjIGEAAYFhgeMggQABiABBiiBDIIEAAYgAQYogQyBRAAGO8FMgUQABjvBUiNUVCWBljIQnABeAGQAQCYAXigAdQUqgEEMjguNbgBA8gBAPgBAZgCIqACxBbCAgoQABiwAxjWBBhHwgILEAAYgAQYsQMYgwHCAggQABiABBixA8ICDhAAGIAEGLEDGIMBGIoFwgIKEAAYgAQYQxiKBcICCBAuGIAEGLEDwgIOEC4YgAQYxwEYjgUYrwHCAggQABgWGAoYHpgDAIgGAZAGCJIHBDI5LjWgB7ngAbIHBDI4LjW4B7oWwgcGMi0yNS45yAfWAQ&sclient=gws-wiz-serp#vhid=zephyr:0&vssid=atritem-"