#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https?|ftp|file):\/\/(www.)?(.*?)\.(mp3)$"
Local $sString = "https://www.soundhelix.com/examples/mp3/SoundHelix-Song-1.mp3" & @CRLF & _
"http://soundhelix.com/examples/mp3/SoundHelix-Song-1.mp3" & @CRLF & _
"http://www.soundhelix.com/examples/mp3/SoundHelix-Song-1.mp3" & @CRLF & _
"ftp://soundhelix.com/examples/mp3/SoundHelix-Song-1.mp3" & @CRLF & _
"file://localhost/examples/mp3/SoundHelix-Song-1.mp3" & @CRLF & _
"file://localhost/examples/mp3/SoundHelix-Song-1.wav" & @CRLF & _
"file://localhost/examples/mp3/SoundHelix-Song-1.avi" & @CRLF & _
"file://localhost/examples/mp3/SoundHelix-Song-1.m4a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")