import re
regex = re.compile(r"^(https?|ftp|file):\/\/(www.)?(.*?)\.(mp3)$", flags=re.MULTILINE)
test_str = ("https://www.soundhelix.com/examples/mp3/SoundHelix-Song-1.mp3\n"
"http://soundhelix.com/examples/mp3/SoundHelix-Song-1.mp3\n"
"http://www.soundhelix.com/examples/mp3/SoundHelix-Song-1.mp3\n"
"ftp://soundhelix.com/examples/mp3/SoundHelix-Song-1.mp3\n"
"file://localhost/examples/mp3/SoundHelix-Song-1.mp3\n"
"file://localhost/examples/mp3/SoundHelix-Song-1.wav\n"
"file://localhost/examples/mp3/SoundHelix-Song-1.avi\n"
"file://localhost/examples/mp3/SoundHelix-Song-1.m4a")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")