# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\G(?!^)|<TAG>(?=.*?<\/TAG>))((?:(?!<TAG>|<\/TAG>).)*?)abc-/$1$2/gs;t' <<< "<TAG>test-test-abc-abc-test-abc-test-</TAG>test-abc-test-abc-<TAG>test-abc-test-abc-abc-</TAG>"