re = /(\G(?!^)|<TAG>(?=.*?<\/TAG>))((?:(?!<TAG>|<\/TAG>).)*?)abc-/
str = '<TAG>test-test-abc-abc-test-abc-test-</TAG>test-abc-test-abc-<TAG>test-abc-test-abc-abc-</TAG>'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result