$re = '/\d+|(?:[^\w\s]|_)+|[^\W\d_]+/m';
$str = 'I2eat!Apples22becauseilike?Them
I2eat!Apples22becauseilike?ThemBLEU34.56';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);