const regex = /([a-zA-Z0-9\\-_]+)=(((["'])((\\{2})*|(.*?[^\\](\\{2})*))\4)|[^\s,]+)[,[\s]*]?/mgiu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z0-9\\\\-_]+)=(((["\'])((\\\\{2})*|(.*?[^\\\\](\\\\{2})*))\\4)|[^\\s,]+)[,[\\s]*]?', 'mgiu')
const str = `username="Mufasa test", realm="testrealm@host.com", nonce="dcd98b7102dd2f0e8b11d0f600bfb0c093", uri="/dir/index.html", qop=auth, nc=00000001, cnonce="0a4f113b", response="6629fae49393a05397450978507c4ef1", opaque="5ccc069c403ebaf9f0171e9517f40e41"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}