re = /([a-zA-Z0-9\\-_]+)=(((["'])((\\{2})*|(.*?[^\\](\\{2})*))\4)|[^\s,]+)[,[\s]*]?/mi
str = 'username="Mufasa test", realm="testrealm@host.com", nonce="dcd98b7102dd2f0e8b11d0f600bfb0c093", uri="/dir/index.html", qop=auth, nc=00000001, cnonce="0a4f113b", response="6629fae49393a05397450978507c4ef1", opaque="5ccc069c403ebaf9f0171e9517f40e41"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end