using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"data-gua-list-category=""([^""]+?)"">[\s\S]+<span>\((\d+)\)";
string input = @"data-gua-list-category="" Metal ""> Metal <span>(2666)<";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}