$re = '/data-gua-list-category="([^"]+?)">[\s\S]+<span>\((\d+)\)/m';
$str = 'data-gua-list-category=" Metal "> Metal <span>(2666)<';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);