#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"logUser"\s*\:([^\,]+),"
Local $sString = "{" & @CRLF & _
" "id": 1," & @CRLF & _
" "numeracao": "001"," & @CRLF & _
" "logUser": 100," & @CRLF & _
" "permissionario": {" & @CRLF & _
" "id": 3113715," & @CRLF & _
" "nome": "ARTHUR MATHEUS SÉRGIO DA SILVA"," & @CRLF & _
" "dataDeNascimento": "2000-12-10"," & @CRLF & _
" "endLogradouro": "RUA TERESINA"," & @CRLF & _
" "endNumero": "89465468"," & @CRLF & _
" "endBairro": "ROSA DOS VENTOS"," & @CRLF & _
" "endCidade": "PARNAMIRIM"," & @CRLF & _
" "endUf": "RN"," & @CRLF & _
" "endCep": "59142125"," & @CRLF & _
" "endComplemento": null," & @CRLF & _
" "telefoneFixo": null," & @CRLF & _
" "telefoneMovel": "(94) 949849849"," & @CRLF & _
" "email": null," & @CRLF & _
" "logDate": "2019-01-16"," & @CRLF & _
" "logUser": null," & @CRLF & _
" "sexo": "MASCULINO"," & @CRLF & _
" "foto": null," & @CRLF & _
" "cpf": "10322314593"," & @CRLF & _
" "estadoCivil": "CASADO"," & @CRLF & _
" "cnhNumero": null," & @CRLF & _
" "cnhCategoria": null," & @CRLF & _
" "cnhValidade": null," & @CRLF & _
" "rgNumero": "64684654"," & @CRLF & _
" "rgOrgaoExpeditor": "SSP"," & @CRLF & _
" "rgDataEmissao": null," & @CRLF & _
" "rgUF": "RN"," & @CRLF & _
" "status": true" & @CRLF & _
" }," & @CRLF & _
" "veiculo": { " & @CRLF & _
" "id": 3," & @CRLF & _
" "placa": "JUQ9196"," & @CRLF & _
" "marca": "RENAULT"," & @CRLF & _
" "modelo": "SC"," & @CRLF & _
" "renavam": "54840252144"," & @CRLF & _
" "anoDeFabricacao": "2006"," & @CRLF & _
" "corPredominante": "BRANCO"," & @CRLF & _
" "logCidadao": null," & @CRLF & _
" "status": true," & @CRLF & _
" "logUser": null," & @CRLF & _
" "logDate": "2019-01-16T11:05:10.425"," & @CRLF & _
" "version": 1" & @CRLF & _
" }," & @CRLF & _
" "logDate": "2019-01-16T11:05:13.264"," & @CRLF & _
" "status": true," & @CRLF & _
" "version": 0," & @CRLF & _
" "motorista": {" & @CRLF & _
" "id": 3113717," & @CRLF & _
" "nome": "DAVI LEVI GALVÃO"," & @CRLF & _
" "dataDeNascimento": "1996-10-20"," & @CRLF & _
" "endLogradouro": "RUA FRANCISCO FERREIRA DA SILVA"," & @CRLF & _
" "endNumero": "911"," & @CRLF & _
" "endBairro": "VALE DO SOL"," & @CRLF & _
" "endCidade": "PARNAMIRIM"," & @CRLF & _
" "endUf": "RN"," & @CRLF & _
" "endCep": "59143025"," & @CRLF & _
" "endComplemento": null," & @CRLF & _
" "telefoneFixo": "8429884472"," & @CRLF & _
" "telefoneMovel": "84995302167"," & @CRLF & _
" "email": "ddavilevigalvao@mtic.net.br"," & @CRLF & _
" "logDate": "2019-01-16"," & @CRLF & _
" "logUser": null," & @CRLF & _
" "sexo": "MASCULINO"," & @CRLF & _
" "foto": null," & @CRLF & _
" "cpf": "98842966428"," & @CRLF & _
" "estadoCivil": "CASADO"," & @CRLF & _
" "cnhNumero": null," & @CRLF & _
" "cnhCategoria": null," & @CRLF & _
" "cnhValidade": null," & @CRLF & _
" "rgNumero": "184962122"," & @CRLF & _
" "rgOrgaoExpeditor": "SSP"," & @CRLF & _
" "rgDataEmissao": null," & @CRLF & _
" "rgUF": "RN"," & @CRLF & _
" "status": true" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")