import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"logUser\"\\s*\\:([^\\,]+),";
final String string = "{\n"
+ " \"id\": 1,\n"
+ " \"numeracao\": \"001\",\n"
+ " \"logUser\": 100,\n"
+ " \"permissionario\": {\n"
+ " \"id\": 3113715,\n"
+ " \"nome\": \"ARTHUR MATHEUS SÉRGIO DA SILVA\",\n"
+ " \"dataDeNascimento\": \"2000-12-10\",\n"
+ " \"endLogradouro\": \"RUA TERESINA\",\n"
+ " \"endNumero\": \"89465468\",\n"
+ " \"endBairro\": \"ROSA DOS VENTOS\",\n"
+ " \"endCidade\": \"PARNAMIRIM\",\n"
+ " \"endUf\": \"RN\",\n"
+ " \"endCep\": \"59142125\",\n"
+ " \"endComplemento\": null,\n"
+ " \"telefoneFixo\": null,\n"
+ " \"telefoneMovel\": \"(94) 949849849\",\n"
+ " \"email\": null,\n"
+ " \"logDate\": \"2019-01-16\",\n"
+ " \"logUser\": null,\n"
+ " \"sexo\": \"MASCULINO\",\n"
+ " \"foto\": null,\n"
+ " \"cpf\": \"10322314593\",\n"
+ " \"estadoCivil\": \"CASADO\",\n"
+ " \"cnhNumero\": null,\n"
+ " \"cnhCategoria\": null,\n"
+ " \"cnhValidade\": null,\n"
+ " \"rgNumero\": \"64684654\",\n"
+ " \"rgOrgaoExpeditor\": \"SSP\",\n"
+ " \"rgDataEmissao\": null,\n"
+ " \"rgUF\": \"RN\",\n"
+ " \"status\": true\n"
+ " },\n"
+ " \"veiculo\": { \n"
+ " \"id\": 3,\n"
+ " \"placa\": \"JUQ9196\",\n"
+ " \"marca\": \"RENAULT\",\n"
+ " \"modelo\": \"SC\",\n"
+ " \"renavam\": \"54840252144\",\n"
+ " \"anoDeFabricacao\": \"2006\",\n"
+ " \"corPredominante\": \"BRANCO\",\n"
+ " \"logCidadao\": null,\n"
+ " \"status\": true,\n"
+ " \"logUser\": null,\n"
+ " \"logDate\": \"2019-01-16T11:05:10.425\",\n"
+ " \"version\": 1\n"
+ " },\n"
+ " \"logDate\": \"2019-01-16T11:05:13.264\",\n"
+ " \"status\": true,\n"
+ " \"version\": 0,\n"
+ " \"motorista\": {\n"
+ " \"id\": 3113717,\n"
+ " \"nome\": \"DAVI LEVI GALVÃO\",\n"
+ " \"dataDeNascimento\": \"1996-10-20\",\n"
+ " \"endLogradouro\": \"RUA FRANCISCO FERREIRA DA SILVA\",\n"
+ " \"endNumero\": \"911\",\n"
+ " \"endBairro\": \"VALE DO SOL\",\n"
+ " \"endCidade\": \"PARNAMIRIM\",\n"
+ " \"endUf\": \"RN\",\n"
+ " \"endCep\": \"59143025\",\n"
+ " \"endComplemento\": null,\n"
+ " \"telefoneFixo\": \"8429884472\",\n"
+ " \"telefoneMovel\": \"84995302167\",\n"
+ " \"email\": \"ddavilevigalvao@mtic.net.br\",\n"
+ " \"logDate\": \"2019-01-16\",\n"
+ " \"logUser\": null,\n"
+ " \"sexo\": \"MASCULINO\",\n"
+ " \"foto\": null,\n"
+ " \"cpf\": \"98842966428\",\n"
+ " \"estadoCivil\": \"CASADO\",\n"
+ " \"cnhNumero\": null,\n"
+ " \"cnhCategoria\": null,\n"
+ " \"cnhValidade\": null,\n"
+ " \"rgNumero\": \"184962122\",\n"
+ " \"rgOrgaoExpeditor\": \"SSP\",\n"
+ " \"rgDataEmissao\": null,\n"
+ " \"rgUF\": \"RN\",\n"
+ " \"status\": true\n"
+ " }\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}