using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[ก-๙])(\d{5})|(\d{5}(?=\d{10,11}))|(?<=\s)([\d]{5}(?=\s))";
string input = @"ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จ.อุบล 34000
กันธิชา. ฤกษจันทร์ 64/10พุนพินมะลวนสุราษฎร์ธานี8413066936166649, พุนพิน
ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จ.อุบล34000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}