$re = '/(?<=[ก-๙])(\d{5})|(\d{5}(?=\d{10,11}))|(?<=\s)([\d]{5}(?=\s))/m';
$str = 'ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จ.อุบล 34000
กันธิชา. ฤกษจันทร์ 64/10พุนพินมะลวนสุราษฎร์ธานี8413066936166649, พุนพิน
ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จ.อุบล34000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);