use strict;
my $str = '"[{\'index\': 0, \'spent_transaction_hash\': \'4b3e9741022d4\', \'spent_output_index\': 68, \'script_asm\': \'3045022100e9e2280f5e6d965ced44\', \'value\': Decimal(\'381094.000000000\')}\\n {\'index\': 1, \'spent_transaction_hash\': \'0cfbd8591a3423\', \'spent_output_index\': 2, \'script_asm\': \'3045022100a\', \'value\': Decimal(\'3790496.000000000\')}]"
';
my $regex = qr/'spent_transaction_hash'\: '([a-z0-9]+)'/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}