re = /'spent_transaction_hash'\: '([a-z0-9]+)'/m
str = '"[{\'index\': 0, \'spent_transaction_hash\': \'4b3e9741022d4\', \'spent_output_index\': 68, \'script_asm\': \'3045022100e9e2280f5e6d965ced44\', \'value\': Decimal(\'381094.000000000\')}\\n {\'index\': 1, \'spent_transaction_hash\': \'0cfbd8591a3423\', \'spent_output_index\': 2, \'script_asm\': \'3045022100a\', \'value\': Decimal(\'3790496.000000000\')}]"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end