$re = '/^.*(?<!(w|W)orld).*(H|h)ome.*(\.|!)$/m';
$str = 'World is now behind you, the home is ahead!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);