import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[\\s_-])\\d+(?:\\.\\d+){1,3}";
final String string = "VendorSetup-2022-05-x64-1.23.4.exe\n"
+ "VendorSetup-x64-1.23.4-2022-05.exe\n"
+ "VendorSetup-1-2-3-4.exe\n"
+ "VendorSetup_2022-05_1-2-3-4.exe\n"
+ "Vendor Setup 1.23.456Update.exe\n"
+ "SoftwareName-1.2.34.5-x64.msi\n"
+ "SoftwareName-1.2.3.4-64bit.msi\n"
+ "SoftwareName-64-Bit-1.2.3.4.msi\n"
+ "VendorName_SoftwareName_64_1.2.3_Setup.exe\n"
+ "NoVersion.exe";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}