# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=[\s_-])\d+(?:\.\d+){1,3}"
test_str = ("VendorSetup-2022-05-x64-1.23.4.exe\n"
"VendorSetup-x64-1.23.4-2022-05.exe\n"
"VendorSetup-1-2-3-4.exe\n"
"VendorSetup_2022-05_1-2-3-4.exe\n"
"Vendor Setup 1.23.456Update.exe\n"
"SoftwareName-1.2.34.5-x64.msi\n"
"SoftwareName-1.2.3.4-64bit.msi\n"
"SoftwareName-64-Bit-1.2.3.4.msi\n"
"VendorName_SoftwareName_64_1.2.3_Setup.exe\n"
"NoVersion.exe")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.