package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\d*\.?\d+%`)
var str = `6% or 5.2% etc.
2 or 0.05 or A`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}