$re = '/\b\d*\.?\d+%/';
$str = '6% or 5.2% etc.
2 or 0.05 or A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);