# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<a href="([^"]*)"\s*class="(?:[^"]* )?mfp_thumb.*(?: [^"]*)?"[^>]*>\s*([^\s].*?[^\s])\s*<\\/a>)/{modal url="$2"}$3/sUmg;t' <<< "blah blah <a href=\"test.html\">Outside of scope</a> blah blah
<a href=\"/about/team/management/tony-georgis\" class=\"mfp_thumb_pos_top\" itemprop=\"url\"><img src=\"/images/thumbnails/mod_minifrontpage/43_642_default.jpg\" width=\"400\" height=\"400\" alt=\"Tony Georgis, P.E.\"></a>
blah blah <a class=\"test\" id=\"one\">Nothing</a> blah blah
"