re = /("blocked-uri":)"(.*?)"(,)/m
str = '"blocked-uri":"https://www.google.com",
"blocked-uri":"https://www.google.com",
"blocked-uri":"https://www.google.com",
"blocked-uri":"https://www.google.com",
"blocked-uri":"https://www.google.com",'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end