#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w+([.|-])\w+\1\d+\1\d+"
Local $sString = "abcd.efgh.1234.4567" & @CRLF & _
"abcd-efgh-1234-4567" & @CRLF & _
"abcd|efgh|1234|4567" & @CRLF & _
"abcd.efgh-1234|4567"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")