re = /\w+([.|-])\w+\1\d+\1\d+/
str = 'abcd.efgh.1234.4567
abcd-efgh-1234-4567
abcd|efgh|1234|4567
abcd.efgh-1234|4567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end