package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d+\.)*\d+$`)
var str = `12.32.12.123
1232.1223
12
12.21.
.12.12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}