$re = '/^(?:\d+\.)*\d+$/m';
$str = '12.32.12.123
1232.1223
12
12.21.
.12.12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);