using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![a-zá])word(?![a-zá])";
string input = @"""word"" (false, true) -> this case doesn't work and should match
""word "" (with a space, true, true)
"" word"" (false, true)
"" word "" (true, true)
""nonword"" (true, false) -> this case works correctly and shouldn't match
"" nonword"" (true, false)
""nonword "" (false, false) -> this case doesn't work correctly and shouldn't match
"" nonword "" (false, false)
""This is a sentence with word in it."" (true, true)
""word."" (true, true)
""This is a sentence with nonword in it."" (false, false)
""wordy"" (true, false)
""wordy "" (true, false)
"" wordy"" (true, false)
"" wordy "" (true, false)
"" áword ""
"" wordá "" ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}