import Foundation
let pattern = #"(?<![a-zá])word(?![a-zá])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"word" (false, true) -> this case doesn't work and should match
"word " (with a space, true, true)
" word" (false, true)
" word " (true, true)
"nonword" (true, false) -> this case works correctly and shouldn't match
" nonword" (true, false)
"nonword " (false, false) -> this case doesn't work correctly and shouldn't match
" nonword " (false, false)
"This is a sentence with word in it." (true, true)
"word." (true, true)
"This is a sentence with nonword in it." (false, false)
"wordy" (true, false)
"wordy " (true, false)
" wordy" (true, false)
" wordy " (true, false)
" áword "
" wordá "
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)