using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"W(indows|INDOWS)9?[58]";
string input = @"windows95
windows98
Windows98
WINDOWS95
windowsXP
windows2000
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}