re = /W(indows|INDOWS)9?[58]/m
str = 'windows95
windows98
Windows98
WINDOWS95
windowsXP
windows2000
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end