re = /VERS=\(([^)]+)\);UUID=\(([^)]+)\);/m
str = 'VERS=(abc-def);UUID=(abc-def-ghi-jkl);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end