using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z])(\1+)";
string input = @"DI,III.II => DI,IZZ.IZ
B,EFF.HH => B,EFZ.HZ
CEE,EEE.BB => CEZ,ZZZ.BZ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}