import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z])(\\1+)";
final String string = "DI,III.II => DI,IZZ.IZ\n"
+ "B,EFF.HH => B,EFZ.HZ\n"
+ "CEE,EEE.BB => CEZ,ZZZ.BZ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}