$re = '/(?<!\bM )(?<!\bMme )\bet\b/m';
$str = 'M et Mme Du Pont or Mme et M Du Pont another et';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);