re = /(?<!\bM )(?<!\bMme )\bet\b/m
str = 'M et Mme Du Pont or Mme et M Du Pont another et'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end