package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|[^&])( COMPANY| CO[.]?)$`)
var str = ` COMPANY
CO
CO.
& COMPANY
& CO
& CO.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}