re = /(^|[^&])( COMPANY| CO[.]?)$/m
str = ' COMPANY
CO
CO.
& COMPANY
& CO
& CO.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end