package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((\b[A-zÀ-ú']{2,40}\b)\s*){2,}$`)
var str = `joao Stafin`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}