$re = '/^((\b[A-zÀ-ú\']{2,40}\b)\s*){2,}$/m';
$str = 'joao Stafin';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);