using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[A-Za-z])(?=.*\d)[A-Za-z\d!""#$%&'()*+,-.\/:;<=>?@[\]^_`{|}~\\\\]{8,}$";
string input = @"Ts\asdasdasd2";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}