re = /^(?=.*[A-Za-z])(?=.*\d)[A-Za-z\d!"#$%&'()*+,-.\/:;<=>?@[\]^_`{|}~\\\\]{8,}$/
str = 'Ts\\asdasdasd2'
# Print the match result
str.match(re) do |match|
puts match.to_s
end