re = /(\w[-\w]+){2,}/m
str = 'stackoverflow.stack.com/read/this-is-a-very-nice-test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end