package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([ies|wv|inn].*?\.mentorg\.com)`)
var str = `ies.mentorg.com
iesa.mentorg.com
iesa.menta.mentorg.mentorg.com
somementorg.com
wv.is.anothermentorg.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}