$re = '/([ies|wv|inn].*?\.mentorg\.com)/m';
$str = 'ies.mentorg.com
iesa.mentorg.com
iesa.menta.mentorg.mentorg.com
somementorg.com
wv.is.anothermentorg.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);